I just got a call that the BlackBerry Administration Service is no longer running. It appliers that it was easy to fix.

 

A deeper look into the system showed that the services:

 

- BlackBerry Administration Service - Native Code Container

- Blackberry Administration Service - Application Server

wheren´t running. When I checked the webservice logfiles I saw the following:

14.03.2011 22:02:46 org.apache.catalina.startup.Embedded start
INFO: Starting tomcat server
14.03.2011 22:02:47 org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.28
14.03.2011 22:02:47 org.apache.catalina.startup.ContextConfig defaultWebConfig
INFO: No default web.xml
14.03.2011 22:02:48 org.apache.catalina.core.ApplicationContext log
INFO: AdministrationController (Status):init
14.03.2011 22:02:48 org.apache.catalina.core.ApplicationContext log
INFO: C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Server\MDS\Servers\Instance
14.03.2011 22:02:48 org.apache.catalina.startup.ContextConfig defaultWebConfig
INFO: No default web.xml
14.03.2011 22:36:58 org.apache.catalina.startup.Embedded start
INFO: Starting tomcat server
14.03.2011 22:36:59 org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.28
14.03.2011 22:36:59 org.apache.catalina.startup.ContextConfig defaultWebConfig
INFO: No default web.xml
14.03.2011 22:37:00 org.apache.catalina.core.ApplicationContext log
INFO: AdministrationController (Status):init
14.03.2011 22:37:00 org.apache.catalina.core.ApplicationContext log
INFO: C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Server\MDS\Servers\Instance
14.03.2011 22:37:00 org.apache.catalina.startup.ContextConfig defaultWebConfig
INFO: No default web.xml

And nothing more... I checked the changelog from the Blackberry system and found out that the system administrator installed the MS Windows updates:

  • Hotfix for MS10-021 related to Microsoft KB979683
  • Hotfix for MS10-047 related to Microsoft KB981852
  • Hotfix for MS11-011 related to Microsoft KB2393802

But http://www.blackberry.com/btsc/KB23927 didn´t allow these updates (which could be the root cause of this issue). I quickly removed the hotfixes and rebooted the server which solved the issue.

 

Leave your comments

Post comment as a guest

0

Comments

    • No comments found